Handmade Hero » Forums » Code » Day 001: Unable to configure Debug Options in VS2019 for the exe
Aargonian
Aaron
2 posts
#21379 Day 001: Unable to configure Debug Options in VS2019 for the exe
1 month, 2 weeks ago Edited by Aaron on Aug. 4, 2019, 9:08 a.m. Reason: Initial post

Hello, I just found Handmade Hero and the project seems really awesome! I've followed the C Tutorials all the way through and just started Day 001. Everything has gone well except that I can't set debug options for the win32_handmade.exe file. I can successfully build the file, and run it outside of Visual Studio, as expected. I can also actually debug the exe in Visual Studio successfully, both with F11 and F5, no problems. However, if I attempt to set the options on the exe so that I can set the default working directory or specifify command arguments, I cannot do so. The configuration screen is completely blank, with no options to set. Right-clicking on win32_handmade in the Solution Explorer does bring up a context menu with Properties, but the properties window is completely blank. The Configuration and Platform dropdowns are both grayed out with the values "N/A". I can't seem to create a configuration, either.

I've tried googling around both in the forums and just generally online to see if anyone has posted about this before, but was unable to find anything that noted this particular issue. I apologize if it's been addressed before.

Has anyone experienced these issues or know what may be causing them? It's incredibly frustrating to not be able to set these options, as I'm sure they'll be important once I get to any of the episodes involving assets. Thanks to anyone for giving this question any consideration!
mmozeiko
Mārtiņš Možeiko
1971 posts / 1 project
#21380 Day 001: Unable to configure Debug Options in VS2019 for the exe
1 month, 2 weeks ago Edited by Mārtiņš Možeiko on Aug. 4, 2019, 9:32 a.m.


Same here with VS2019. Probably a bug in IDE. I suggest reporting an issue in Help -> Send Feedback -> Report a problem...

What I found is that if you exit VS, it will ask you save the sln file. You do that. Then you open saved sln file in notepad where you can change "StartingDirectory" path to whatever you want. After that sln file and working directory will be set to value you entered.
Aargonian
Aaron
2 posts
#21381 Day 001: Unable to configure Debug Options in VS2019 for the exe
1 month, 2 weeks ago

Well that's most unfortunate. I was really hoping that it may just be something stupid I didn't know about or something I had done wrong. I'll try to install VS 2017 or 2013 before I go manually editing the sln file, though. Thanks for the response!
immortalx
John
22 posts
#21382 Day 001: Unable to configure Debug Options in VS2019 for the exe
1 month, 2 weeks ago

You're a lifesaver Mārtiņš. I spent all of today's morning, after installing vs2019, trying to debug my project and set the start path. I confirm your solution works perfectly.
Me and my son were literally pulling our hair out trying to get to the project settings!
lito
Axel Daguerre
2 posts
#21453 Day 001: Unable to configure Debug Options in VS2019 for the exe
1 month ago Edited by Axel Daguerre on Aug. 17, 2019, 4:16 p.m.

It happens to me either, i am reinstalling Visual Studi, i will try your solution when it is done. I have an other unfortunate issue too, i dont see the message from my OutputDebugStringA() on the output window in VS, i have all options checked when you do a right click, have you go the same issue ?

EDIT: Actually i reinstall my visual studio more exactly "repair" and now i have the output displaying, maybe it was something to do with my settings, and the solution above for the blank page worked. Thanks